Delphi 11.3 [dcc32 Fatal Error] Projectx.dpr(1): F1027 Unit not found: 'System' or binary equivalents (.dcu)

Logged in this morning and got this error when trying to compile a project I was working on yesterday. No problems. System shot down overnight.

Created a new VCL project, form only, and the same error was reported.

Googled most of the day, nothing I found worked.

In the Tools/Options/Language/Delphi/Library are the following paths
C:\Program Files (x86)\Embarcadero\Studio\22.0\source\rtl\sys (System.pas is in this directory)
C:\Program Files (x86)\Embarcadero\Studio\22.0\lib\win32\debug (System.dcu is in this directory)
C:\Program Files (x86)\Embarcadero\Studio\22.0\lib\win32\release (System.dcu is in this directory)

Interestingly for the blank (form only) project I got 442 Warnings. I think this is the clue to the cause of the problem, but not sure where to look to determine the cause/s of the warnings. Typical warnings are

[dcc32 Warning] W1030 Invalid compiler directive: ‘VCL’
[dcc32 Warning] W1030 Invalid compiler directive: ‘Security’
All 442 warnings have the same W1030 number.

With a ‘blank’ project there are no compiler directive in the source code
Just cannot find where the’other ‘VCL’ and ‘Security’ compiler directive are to try to see what has gone wrong.

I see an identical F1027 error reported her back in Feb 2012, ADUG archive, can’t access it or responses.

Any clues appreciated.
Cheers, Paul.

You can search this forum for ‘F1027’.
I believe it has all(?) of the old email archive transferred over.
I see entries coming up mentioning the LSP …

FYI, the Email archive is only available to financial ADUG members.

FYI I am financial :upside_down_face:

I would check you don’t have a broken system path variable

Then uninstall, reboot and reinstall

You might have installed a component before you shut down and the new broken system path most likely because it’s too long didnt kick in until you started up again

Obviously I can’t see your computer so I’m just guessing

Not sure why you cannot see the posts then, I checked the security settings and they are visible to people in the ADUGMembers group, which you are.

All the posts in the mail archive category are read only, they were imported from the email list and no all the post authors are still with us or part of adug now.

Perhaps check your Antivirus, see if it has deleted anything.
Get the AV to update itself and see if things then work.
Try disconnecting internet, and disabling AV, see if it works.

A bit embarrassing. After all the reboots, cache clearing, path editing, etc I think I was not logged in to the forum, so couldn’t search. This is just my take on the events, maybe wrong.

Eventually got to search, nothing suggested worked, links in the forum and googled did not work or were no longer available.

I went through the library path and removed links that did not exist.
Then got errors that said procedures/functions were missing or files were corrupted.

Looking at the system event logs, I saw that a windows update was in progress and possibly had not finished when a scheduled shutdown happened. Don’t really know as logged times had big gaps .

Uninstalled all third party components , then Delphi. rebooted and reinstalled. As not much had to be downloaded it took a lot less time than I originally estimated. Polar opposite to my project time estimates.

Thanks for all the replies. Know what to do next time.
Cheers Paul.