Install error "EULA declined" with Network Named License for Alexandria 11.1

During install of Alexandria 11.1 onto a clean VM, (no prior Delphi version) with a Network Named license I am getting the message “Operation error - EULA declined” after selecting the platforms and optional components to install.


I have of course been sure to tick the checkbox to agree to the license agreement during the install.

When the License Manager appears earlier in the install process I successfully install my slip file without a problem. I have tried using updated slip files by going through the ELC host license procedure but that doesn’t help.

Unfortunately it’s starting to look like Alexandria 11.1 cannot be installed on Windows 7.

Win7 hasn’t been a supported platform for quite a few years now but I haven’t had any problems using any Delphi version with it up until today.

I just tried a minimal install of 11.1 onto Win7, with just the Win32 platform and no optional components. That gives a different error message “Cannot load data from the server: Error sending Data: (12175) A security error occurred”


Installing into a Win10 VM worked just fine.

Farewell Windows 7, you’ve been my trusted companion for a long time now. It’s not going to be the same without you.

I’ve got 11.1 installed on Windows 7 here and it’s working fine.

Might still be a problem doing a fresh install onto Windows 7 though as I upgraded from 11.0

Mark and I worked out the reason for the differences we’re seeing and what the root cause of the incompatibility is.

I’m using the web installer while Mark is using the ISO installer. I get the issue when the web installer first goes to download its files while for Mark of course they’re already there on the ISO.

Based on the error code above (12175) we’re theorising that the 11.1 web installer requires TLS 1.3. There is no Windows 7 support for TLS 1.3, only TLS 1.2.

So I went with the Alexandria 11.1 ISO and installed it in my Win7 VMs. That went fine but I’m regretting the decision.

It turns out though that GetIt in 11.1 uses TLS1.3 and while you can view the contents of GetIt, you get the 12175 error or something similar if you try and install anything via GetIt.

Not a problem you say, I don’t use GetIt. Well you actually do use it, the IDEs auto-updating mechanism is based on GetIt.

You can still download the IDE patches manually, but after experiencing the joy of an auto-updating IDE, I don’t want to go back to manual downloads and installs, then having to remember which VMs I’ve patched or not.

There’s also a few things these days that you can only get via GetIt. The bundled FastReports comes to mind and I think there’s a few others.

I’ll get by with hacks and workarounds for now but regrettably it is time to retire Win7 and move to Win10 based virtual machines.

Not sure if this would work, but might be worth trying.

You could install telerik fiddler classic and enable it to do https intercept.
It will likely force a downgrade to tls1.2

Isn’t there a registry modification for ISO-installations, to fix the Getit thing?

If you use the offline installer, RAD Studio will not be able to access the GetIt Package Manager until you manually switch to “online mode”. To do this, we recommend using the GetItCmd.exe tool: GetItCmd.exe -c=useonline

I only know this from Glenn Dufke on fb … Release Notes - RAD Studio

Edit → Oh ok, … I see … TLS issue. Getit. Gotit. Good.

Like Parnassus, for instance. Seems to have disappeared despite being promoted earlier.