Thoughts about Delphi 11

I have reported another Bug for FMX in Delphi 11.

TLabel.OnClick or OnDblClick does not fire

Log in - Embarcadero Technologies

Documentation Insight for Delphi 11 came out today :blush:

Weirdly, every time I open Delphi 11, I have the right-hand-side margin at 80 columns … and I remove it … aaand … next time it is back again. What? :slight_smile: :sweat_smile:

There is a bug with saving settings, try changing more than one setting and see if that helps (not kidding).

1 Like

Yup. That did it. Now I have no right margin … and am stuck with “show all line numbers”. :rofl:

I’ll check for existing QA entries, but I have some issues from using 4K laptop with a 2K external screen.

I get this resizing when I drag a (nearly full screen) IDE from one to the other. (top)
Almost none of that blue area can be dragged, and you need to widen the window and click where the text is.

This happened during the Melbourne meeting, and I didn’t think to retry it with the IDE on the laptop screen.

The effect of pressing Ctrl+ 5 times for the main screen (4K, 200% scaling) …

vs external (2K, 100% scaling)

If I change both screens to 200% scaling, they both scale properly.
If I change both screens to 100% scaling, they both ‘scale’ ugly.

And the resetting of the IDE window size occurs on going between scaling factors.
(10.4.2 works ok in both regards)

Been using D11 a bit now and had the occasional stall during debugging which means I will probably leave it for a while.

My major issue is that each time I open it it starts in the Welcome Page delaying the startup and requiring me to close it before I get back to the saved layout.

I am sure this is a Feature not a Fault as it Pings Emb every time I start Delphi.

If the Welcome Page is causing trouble, you can disable it by either:

Changing the Value for $(BDS)\Bin\WelcomePageIDE280.bpl in HKCU\Software\Embarcadero\22.0\Known IDE Packages in the registry to prefix it with two underscores (i.e. __Welcome Page IDE Package), or:

Renaming the WelcomePageIDE280.bpl file in the (bds)\bin folder

If I understand your solution this will disable the Welcome Page. I do refer to the welcome page occasionally but I think the benefit it occasional offers is outweighed by the irritation.

I used the Rename Welcome page and after handling a couple of error message on the first start up now have no Welcome Screen

Hello Folks,

I have tried to get 2 of my smaller Delphi 10.4 projects over to Delphi 11 Alexandria.

One that uses the VCL components only works fine. The other one, which uses Konopka Signature VCL Controls (KSVC) and has custom-built UI controls based that package, fails with:

E2225 Never-build package ‘RaizeComponentsVcl’ must be recompiled

So I removed the required packages RaizeComponentsVcl & RaizeComponentsVclDb from my component package based on KSVC and tried to recompile. This is when I got the following error message

F2051 Unit RzCommon was compiled with a different version of Vcl.Forms.TCustomForm

I searched the Internet and found an article on Delphi-PRAXIS forum here that mentions a work-around and the fact that Embarcadero has temporarily removed KSVC from the GetIt package manager. I think I wait until they get the deployment right.

My other components I used are available for Delphi 11 already:

  • TMS VCL Cloud Pack
  • TMS Web Update
  • FastReport

MadExcept is still a beta version for Delphi 11 but should not change any more according to the author here.

I am very close to get the second project going too.


Can anyone select their mobile as a target for debugging ? It will not show my mobile in the list under Android 32 or 64. Its usb debugging is on. And I have reinstalled the IDE 3 times now. It definitely installed the 3 Android SDKs.

Is your problem allowing you to select the platform or seeing your mobile under
Android Target? Did you successfully have your mobile present in 10.4?

Assuming it is the Target issue.
1/ Is your phone setup correctly. Developer On etc.
2/ Is your Phone Supported

3/ Getting the phone to play part is also an issue.
a/ In a VM insure the phone is attached to the VM
b/ Can you see the Phone in Explorer
c/ Right Click Refresh on the target in Delphi
d/ check the phone for Alerts requesting permissions
e/ @##@!

Yes it used to work in previous versions. Which is why I was using the old phone rather than the latest one. After an hour of the IDE being alive, it finally detected the phone. I can send it the app, it runs the default firemonkey flash screen and then nothing.

The app, while not finished, has a lot in it. It runs on windows. Maybe, I will now try a classic hello world :slight_smile:

1 Like

The Raize components have been updated and resolve the compiled with different version issue.

Updating from the GetIt package manager yesterday fixed the issue for me.

Thanks Wayne. I had to uninstall the components and re-install them before my package compiled again.


You might want to look at the thread Under FMX this was a problem I had on old projects from earlier Delphi Versions. If you find a better solution let me know.

I am sure there is a better way to put in Discourse Cross References. Someone might let me know how.

My experiences with it so far. For now, I have been focusing on mobile apps and deploying a webserver to Linux with this in D11. Because they are new projects. The Linux fiasco has taken too much of my time.

  1. The Linux SDK gets installed on drive C. Arrgghhh. The property to change this path only surfaces after D11 has installed it. Hopefully I can fiddle the registry entry and shift it later.
  2. The RemotePath property has not been surfaced so it installs into a convoluted path under scratch-dir on Linux.
  3. I have a simple server working under windows and I deployed it to Linux. It just wouldnt work. I think it was missing files. I copied from my PC’s linux/release and it worked a little better.
  4. Yesterday, I refactored the original default code that the wizard provides (so that its readable) and added an auto-start parameter. This works on Windows. But when I deploy to Linux, the three folders linux/release, linux/debug and scratch-dir have different versions of the js files and none of them have the recent changes. I rebuilt, rebooted and rebuilt but no joy. They have the code from two days ago.
  5. I wiped the above directories clean and rebuilt, but its still the same.
  6. On Linux, the binary has an updated timestamp but when it runs, it is using the code from 2 days ago. Where is it getting this old code from (but only for Linux) ?

Is anyone working on Linux ? I am planning to use D10 for the next few days. This will prove whether its user error or a bugs in D11.

I tried the same project in D10. It behaved in the same manner.

So, I think I found the main problem. I routinely use Save As to shift/clone projects to different folders. This normally works fine, if you save a pas file, the dfm file follows. In this case it didnt shift the resources over with the project (such as js, and html). It made a new copy in the new folder but the reference in the project file was to the old location.

The kicker is that the editor used the new location. So did the Windows compile. But the Linux compile used the old location (and hence the old code). So I was testing with the new code but deploying the old code which was also mangled.

I could fix it by changing the references. But to prove that D11 is okay, I am starting a new project, then I will merge my changes back.